Centos7.9使用yum出现Error: xz compression not available提示解决办法

Centos7.9使用yum出现Error: xz compression not available提示解决办法

Design.
2022-10-28 / 0 评论 / 9 阅读 / 正在检测是否收录...
温馨提示:
本文最后更新于2022年10月28日,已超过41天没有更新,若内容或图片失效,请留言反馈。

使用yum安装任何工具都提示Error: xz compression not available大概率是安装了和系统不匹配的版本。
1.下载与系统匹配的版本 https://mirrors.aliyun.com/epel/ Centos7下载epel-release-latest-7.noarch.rpm,如果是Centos8 下载与之对应的即可
微信截图_20221028143750.png
使用wget命令下载

wget https://mirrors.aliyun.com/epel/epel-release-latest-7.noarch.rpm

2.卸载错误的版本

yum remove epel-release

3.清空epel目录

rm -rf /var/cache/yum/x86_64/7/epel/

4.安装epel-release-latest-7.noarch.rpm

rpm -ivh epel-release-latest-7.noarch.rpm

现在使用yum命令安装工具正常了
微信截图_20221028144642.png

0

评论 (0)

取消
本站由提供CDN加速/云储存服务